BODi.com is currently down due to integrated service disruption.

Incident Report for BODi by Beachbody

Resolved

BODi.com is currently operational. We apologize for any inconvenience this may have caused.
Posted Jun 03, 2024 - 09:01 PDT

Investigating

Team is actively working to address the issue.
Posted Jun 03, 2024 - 08:48 PDT
This incident affected: BODi (Web) (Account Creation, Order Placement).