Intermittent BOD Login Issues
Incident Report for BODi On Demand
Resolved
Beachbody On Demand login has returned to operational. We sincerely apologize for any inconvenience this may have caused.
Posted Mar 21, 2020 - 14:38 PDT
Investigating
Beachbody On Demand is currently experiencing intermittent login issues. Our team is troubleshooting and hopes to have this cleared up shortly.
Posted Mar 21, 2020 - 10:29 PDT
This incident affected: Web (Login).