BOD Roku and BOD Android applications are currently down due to an technical issue.
Incident Report for BODi by Beachbody
Resolved
BOD applications on Roku and Android are now operational. We apologize we for the inconvenience this may have caused.
Posted Mar 19, 2020 - 08:30 PDT
Investigating
BOD Roku and BOD Android applications are currently down due to an technical issue. Our team is triaging the issue and hopes to have it resolved shortly.
Posted Mar 19, 2020 - 08:14 PDT
This incident affected: BeachbodyonDemand.com (On Demand Streaming).