BOD Community Down
Incident Report for Beachbody On Demand
Resolved
Community is back up on BOD Web. We apologize for any inconvenience this may have caused.
Posted Nov 06, 2019 - 14:42 PST
Investigating
Community forum on BOD Web is currently down due to a third party issue. Our team is investigating the problem further and we are hoping this is resolved shortly.
Posted Nov 06, 2019 - 13:02 PST
This incident affected: Community.