BeachbodyOnDemand.com is experiencing a site outage. Our team of engineers are currently investigating.

Incident Report for BODi by Beachbody

Resolved

The issue has been resolved and the site is operational. We apologize for the inconvenience.
Posted Jun 06, 2024 - 10:37 PDT

Identified

The issue has been identified and we hope to have the site operational momentarily.
Posted Jun 06, 2024 - 10:25 PDT

Investigating

We are currently investigating this issue.
Posted Jun 06, 2024 - 09:20 PDT
This incident affected: BeachbodyonDemand.com (Account Creation, Login, On Demand Streaming, BODgroups, Blog).