BOD Registrations Intermittently Down
Incident Report for BODi On Demand
Resolved
This issue has now been resolved. BOD registration is currently operational across all platforms.
Posted Jan 12, 2021 - 10:00 PST
Investigating
We are currently experiencing intermittent down issues with BOD Registration. Our team is working on resolving the issue and hope to have it resolved shortly.
Posted Jan 12, 2021 - 09:28 PST
This incident affected: Web (Registration).