BOD Video Playback Intermittency

Incident Report for BODi by Beachbody

Resolved

BOD is operational across all platforms. We sincerely apologize for any inconvenience the issue may have caused.
Posted Mar 02, 2021 - 14:04 PST

Investigating

There is an ongoing issue impacting playback across all BOD platforms. The team is aggressively troubleshooting and we hope to have systems restored momentarily.
Posted Mar 02, 2021 - 13:32 PST
This incident affected: BeachbodyonDemand.com (On Demand Streaming).