Intermittent login and video issues on BOD
Incident Report for Beachbody On Demand
Resolved
MCT app is currently functioning on both iOS and Android. All BOD platforms, MCT, and Nutrition+ have returned to normal operations. We will continue to closely monitor performance. We apologize for any inconvenience this may have caused
Posted Jun 10, 2018 - 10:40 PDT
Update
Our team has resolved the issues with BOD and Nutrition+. We are continuing to investigate problems with MCT caused by a provider outage.
Posted Jun 10, 2018 - 09:50 PDT
Update
In addition to BOD login and streaming, we are investigating similar problems with Nutrition+ and MCT apps. We apologize for the inconvenience and hope to have this resolved shortly.
Posted Jun 10, 2018 - 09:30 PDT
Investigating
BOD is currently experiencing intermittent login and video streaming issues. Our team of engineers are investigating and we will provide additional updates as they become available.
Posted Jun 10, 2018 - 09:09 PDT
This incident affected: Video Streaming and Login.