Beachbody On Demand login is currently down across all platforms.
Incident Report for BODi On Demand
Resolved
BOD login is currently operational on all platforms. We sincerely apologize again for the outage and any inconvenience it may have caused. We are taking measures to ensure future occurrences are prevented.
Posted Jan 22, 2020 - 11:55 PST
Investigating
Beachbody On Demand login is currently down across all platforms. We are working on resolving the issue and apologize for the inconvenience.
Posted Jan 22, 2020 - 11:25 PST
This incident affected: Web (Login).