BOD Web Programs Page is Failing to Load Content.
Incident Report for Beachbody On Demand
Resolved
BOD Web has recovered from the content outage and is now fully operational. We apologize for any inconvenience this may have caused.
Posted Oct 27, 2020 - 14:32 PDT
Investigating
BOD Web is experiencing issues showing content on the Web programs page (beachbodyondemand.com/programs). Team is in the process of addressing and hope to have it resolved shortly.
Posted Oct 27, 2020 - 13:23 PDT
This incident affected: Program Content.