Billing and shipping address updates are not saving for continuity orders.

Incident Report for BODi by Beachbody

Resolved

The issue has been resolved. Updates to billing and shipping addresses are correctly being saved and applied to future continuity orders if desired.
Posted Jun 13, 2024 - 11:26 PDT

Investigating

The team has identified an issue preventing billing and shipping address updates from saving for continuity orders. Our engineers hope to have this resolved shortly.
Posted Jun 13, 2024 - 10:29 PDT
This incident affected: Team Beachbody (My Account Management).