Beachbody On Demand currently inaccessible for some users
Incident Report for BODi On Demand
Resolved
BOD login is fully operational across all clients. We apologize for any inconvenience that may have caused
Posted Dec 09, 2019 - 19:22 PST
Investigating
BOD engineers are investigating a login issue impacting some member accounts. We hope to have this resolved shortly.
Posted Dec 09, 2019 - 18:28 PST
This incident affected: Web (Login).