Beachbody on Demand Maintenance
Incident Report for BODi On Demand
Resolved
We have recovered from the maintenance window. All BOD features are operational across all platforms.
Posted Feb 19, 2021 - 00:05 PST
Investigating
As part of a planned maintenance, new account creation will be down across all BOD platforms starting Thursday at 10:00pm pst until Friday at 1:00 am pst. Login, video playback, and all other BOD features will be fully operational during this time. We apologize for any inconvenience this may cause.
Posted Feb 18, 2021 - 22:08 PST
This incident affected: Web (Registration).