Registration is currently down
Incident Report for Beachbody On Demand
Resolved
BODWeb account creation is now operational. We apologize for any inconvenenience this may have caused
Posted Apr 01, 2021 - 12:11 PDT
Identified
There is an issue preventing registration on BODWeb. Team is aggressively working on a solution and hope to have this addressed shortly.
Posted Apr 01, 2021 - 07:36 PDT
This incident affected: Registration.