BOD Intermittent Loading Issues
Incident Report for Beachbody On Demand
Resolved
Our engineers have resolved the issue and we sincerely apologize for any inconvenience this may have caused. If you are continuing to experience any intermittent loading on BOD Web, please follow the steps outlined in the below article for clearing browser cookies. https://faq.beachbody.com/app/answers/detail/a_id/4688/catid/0/TLP/0
Posted Oct 01, 2020 - 11:27 PDT
Investigating
BOD Web is intermittently failing to load for some users. We are in the process of addressing the issue and hope to have it resolved shortly.
Posted Oct 01, 2020 - 11:01 PDT
This incident affected: Login, Registration, and Program Content.